Pages

Wednesday, October 2, 2013

You cannot use the vSphere client to edit the settings of virtual machines of version 10 or higher

As of vSphere 5.5 when you create VMs the default hardware version is 8. However, there is an option to upgrade the virtual hardware to version 10. While I'm sure there are benefits to version 10 over 8, I'm only advising you that in upgrading VM hardware version you will be unable to edit VMs running hardware version 10 using the vSphere client. See picture below..


Furthermore if you read the vSphere 5.5 documentation it goes on to say the following:
If you update the vCenter Server appliance to hardware version 10, you cannot edit the virtual machine settings for the appliance using the vSphere Client. This might cause difficulties in managing the vCenter Server Appliance, because you cannot use the vSphere Web Client to connect directly to the host on which the vCenter Server Appliance resides to manage it. Do not upgrade the vCenter Server Appliance to hardware version 10. VMware vSphere 5.5 Documentation Center
It seems likely VMware is moving vSphere closer to a web only client. It's been talked about for a while but does this mean in version 6.0 the vSphere client will disappear permanently? The question I would ask is if that happens what does it means for the free version of the ESXi hypervisor? If version 6.0 is released and the default VM hardware version is version 10 I could see people making VMs they can't edit. If you have vCenter then you can use the web client so it's a moot point, but for home labs and small offices this could be a big problem.

I wonder if VMware will change this as it moves closer to vSphere 6.0. In vSphere 5.1 there was a hardware version 9, albeit some what experimental. I kind of think version 10 isn't ready for general use or a default hardware version or else VMware would have made it the default when creating VMs in vSphere 5.5. Again, I'm sure there are benefits and use cases, but I would want to have a definitive reason for doing so. Not to say you have to use hardware version 10 at this point, but it would be nice to.